Ständig wiederkehrende Cookie-Frage, Backspace als "Seite zurück" funktioniert nicht mehr

Beiträge
9.048
Ort
81249 München
Liegerad
Optima Cheetah
Trike
HP Gekko
Seit einigen Tagen beobachte ich zwei Dinge, die mich ein wenig nerven:
1) Fast jedes Mal (ca. 9 von 10), wenn ich ein Unterforum oder einen Thread in einem neuen Browser-Tab öffne, kommt wieder die Frage, welche Cookies ich akzeptieren möchte. Ich kann auf "alle ablehnen" klicken oder einige akzeptieren und andere deaktiviert lassen (alle zu akzeptieren habe ich noch nicht probiert), das ändert nichts. Wieso merkt sich das Ding nicht, dass ich schonmal gefragt wurde und was ich da ausgewählt hatte? Das VM-Forum ist die einzige Site, die sich so verhält.
2) Backspace als Browserfunktion "Seite zurück" funktioniert nicht mehr. Früher ging das nur nicht, wenn der Tastaturfokus im Editorfeld stand, jetzt geht es überhaupt nicht mehr. Wie kriege ich das wieder ans Funktionieren?

Da das vermutlich wichtig ist: Ich bin mit Firefox auf Win10 unterwegs, und blockiert werden "Cookies von nicht besuchten Websites".
 
Beiträge
2.195
Ort
55288 Armsheim
Velomobil
Quest
Liegerad
HP Streetmachine
Trike
HP Scorpion fx
Ja, melde mich i.d.R. immer ab. Nehme auch immer den Haken "angemeldet bleiben" raus.

Grüßem
Christian
 

Reinhard

Team
Beiträge
21.518
Ort
48599 Gronau-Epe
Liegerad
Wolf & Wolf AT2
1617541560785.png
 
Beiträge
10.820
Ort
Tettnang Bodensee
Velomobil
Milan SL
1) Fast jedes Mal (ca. 9 von 10), wenn ich ein Unterforum oder einen Thread in einem neuen Browser-Tab öffne, kommt wieder die Frage, welche Cookies ich akzeptieren möchte. Ich kann auf "alle ablehnen" klicken oder einige akzeptieren und andere deaktiviert lassen (alle zu akzeptieren habe ich noch nicht probiert), das ändert nichts. Wieso merkt sich das Ding nicht, dass ich schonmal gefragt wurde und was ich da ausgewählt hatte? Das VM-Forum ist die einzige Site, die sich so verhält.
Das ist Vorgabe der EU, kommt Reinhard nicht drumrum.
Ich musste bisher bei jedem Öffnen des browsers neu ablehnen (alle Cookies bei Schließen löschen). Hat mich nicht gestört, aber nachdem Google mich jetzt gezwungen hat, ein Add-On zu installieren, um den redirect wegzubekommen und ich eh schon aktiv war, habe ich die Frage hier gesehen.

Ich hab etwas rumgetestet, es gibt verschiedene Möglichkeiten:
  • Javascript deaktivieren. Das Forum ist nutzbar, aber sehr unergonomisch.
  • Cookies für velomobilforum.de dauerhaft erlauben. Speichert dann halt alle Cookies dauerhaft. (In Firefox ctrl-i und Berechtigung setzen)
  • Cookies verbieten (FF s.o.). Damit lässt sich das Forum lesend nutzen. Zum Einloggen/Schreiben werden jedoch Cookies benötigt.
  • Für Browser, die das anbieten (Firefox und alle mit Chrome als Engine): Add-On "I don't care about Cookies". Erzeugt das Cookie für "Ablehnen" immer wieder neu, habs verglichen.
Ich nutze dann mal Option 4.

Ich muß sagen, ich bin positiv überrascht, mit wie wenig aktivem Inhalt das Forum noch nutzbar ist, Hut ab @Reinhard

Frohe Ostern,

Tim
 
Beiträge
9.048
Ort
81249 München
Liegerad
Optima Cheetah
Trike
HP Gekko
Das ist Vorgabe der EU, kommt Reinhard nicht drumrum.
Dass das einmal kommen muss, ist klar. Aber doch nicht jedes Mal, wenn ich ein Unterforum oder einen Thread in einem neuen Tab des Browsers aufmache. :confused:
Evtl. hat es etwas damit zu tun, was man für Cookies erlaubt, man kann ja auswählen, dass Cookies von nicht besuchten Websites abgelehnt werden.
Da muss ich mir noch Zeit zum Rumprobieren nehmen. Mit Bordmitteln sieht man in Firefox nicht mehr, welche Cookies gesetzt sind/werden, sondern nur noch, welchen Domains sie zugeordnet sind, und es gibt welche von www.velomobilforum.de und welche von www.herden.net.

Ich will eigentlich gar nicht alle Cookies verbieten, sondern nur den Kram für Aktivitätenverfolgung und interest based ads.

Was mir eben auch noch auffiel: Die Liste der kürzlich benutzten Smileys ist jetzt meistens leer. Ich bin mir sicher, dass ich :cool:, ;) und :cautious: seit dem letzten Firefox-Neustart schon benutzt hatte, aber als ich in diesem Beitrag den "confused"-Smiley eingefügt habe, war noch nichts in der Liste.

Edit:
Es scheint irgendwas mit Ghostery zu tun zu haben. Hab zwar velomobilforum.de da explizit ausgeklammert (schon seit es installiert ist), aber wenn ich das Ghostery-AddOn global im Firefox deaktiviere, kommt die Cookie-Frage nur einmal. Hab's jetzt mal von Hand aktualisiert und herden.net mit in die Ausnahmeliste genommen, mal schauen, ob ich das noch weiter eingrenzen kann. Es sind sowieso nicht viele Tracker blockiert, von Google nur "Google Dynamic Remarketing".
 
Zuletzt bearbeitet:

Reinhard

Team
Beiträge
21.518
Ort
48599 Gronau-Epe
Liegerad
Wolf & Wolf AT2
Es scheint irgendwas mit Ghostery zu tun zu haben.
Ich kann persönlich nur dazu raten, ausschließlich die Einstellung der aktuellen Browser zu nutzen. Ich nutze nie irgendwelche Blocker weil die m.E. nur zusätzliche Arbeit machen ... Wenn hier irgendwer "Blocker" schreibt, bin ich taub, ich hab einfach keine Zeit & Lust, um Probleme mit solchem Mist zu verfolgen.

Das Consent-Tools was ich hier verwende funktioniert recht gut. Wie Tim schon schreibt, komme ich um den Einsatz praktisch nicht drum rum. In der Praxis habe ich das erst bei den Cargobikern eingesetzt und 2-3 Tage mit Fixes verbracht. Die meisten Meldungen kamen dort übrigens von eifrigen Blocker-Nutzern ... Nach dem dann dort Ruhe war, habe ich das hier mit den gleichen Einstellungen installiert und gehe eigentlich davon aus, dass es soweit auch läuft.
 
Beiträge
4.100
Ort
48317 Drensteinfurt
Velomobil
DF XL
Liegerad
Troytec Revolution
Cookies von mehreren Domains können natürlich ein Problem sein.
Bei mir sehe ich aber überhaupt keine Cookies von www.herden.net (und auch nicht von herden.net), sondern nur von velomobilforum.de und www.velomobilforum.de. Ich erinnere mich aber daran, dass es "früher mal" Cookies von (www.)herden.net gab.

Die Gefahr von Cookie-Erlaubnis-Problemchen könnte noch geringer werden, wenn die Cookies wirklich nur von einer Domain kämen; also entweder velomobilforum.de *oder* www.velomobilforum.de.
Aber als ich mich jetzt einmal abgemeldet hatte, alle Cookies gelöscht hatte und neu angemeldet hatte, kamen nur noch Cookies von www.velomobilforum.de. - Klar kam dann auch wieder 1 x die Nachfrage nach der Cookie-Erlaubnis. Da habe ich geantwortet, wie ich das persönlich fast immer halte: "Bitte konfigurieren --> nur funktionale / technisch notwendige Cookies --> speichern".

Und auch mein Einsatz von uBlock Origin macht sich nicht negativ bemerkbar. (Ich bin - anders als Reinhard ;-) - der Meinung, dass das Web ohne Blocker kaum mehr sinnvoll nutzbar ist. Natürlich schaltet man / schalte ich auf meinen "Stamm-Sites" fast alles explizit frei.)
Und explizite Tools muss man inzwischen verwenden, damit man bei Problemen (schon in Browser-Standard-Einstellungen wie bei den jüngsten FF-Versionen) schon einsetzen, weil man sonst gar nicht exakt nachvollziehen kann, was wohl das Problem sein könnte.
Und Menschen ohne tiefere Kenntnis davon, wie "das alles" funktioniert, haben tatsächlich gar keine Chance etwas sinnvolles zu diagnostizieren.

"Blocker aktiv => kein Support" ist nachvollziehbar (und würde ich auch nicht anders handhaben), wird aber kritisch, wenn die Browser zunehmend selbst in diese Rolle schlüpfen. :-/ (Was durchaus sinnvoll ist. Nur die mitgebrachten Werkzeuge zur Verwaltung müssten da noch um einiges handhabbarer "für normale Menschen" werden.)

Fazit: Reinhard macht es hier schon ziemlich gut und "freundlich für strenge Browser".

Tipp: beim Firefox findet sich ganz zu Beginn der URL-Zeile ein Icon in Form eines Schutzschildes. Lässt man die Maus darüber schweben, werden Infos zum Status angezeigt, klickt man drauf bekommt man recht umfassende Infos inkl. eines Links zur Konfiguration.
 
Zuletzt bearbeitet:
Beiträge
9.048
Ort
81249 München
Liegerad
Optima Cheetah
Trike
HP Gekko
Ein Unterschied zwischen "aktuellen Browsern" und Ghostery ist, dass ich bei Ghostery aussuchen kann, welche Elemente auf den Blockierlisten stehen.
Da stehen bei mir auch nicht viele Elemente drauf. Mein Ziel ist eigentlich nicht, jegliche Werbung fernzuhalten, sondern erstens möglichst wenig Datenspuren zu hinterlassen und zweitens die Sachen auszublenden, die eine Seite fast unbenutzbar machen (kreischbunte, laute Video-Overlays u.ä.) Hin und wieder passiert das Löschen der Cookies oder das (De)aktivieren von Addons auch einfach in einem Versuch, das "interest based advertising" zu resetten. Quer über die besuchten Websites hinweg immer dieselbe oder ähnliche Werbung zu sehen nervt nämlich...

Abhilfe innerhalb von Ghostery zu finden wid wohl etwas schwierig. Eine erste Suche nach "CCM19" und "ghostery" ergab nämlich nur Seiten, die selber CCM19 verwenden und zur Vermeidung des Datenexports in die USA den Einsatz von noscript oder ghostery empfehlen. :rolleyes:
 
Beiträge
1.422
Das ist Vorgabe der EU,
Klar, wenn man irgendwelche optionalen persönlichen Daten speichern will, die man nicht speichern muss, dann braucht man die Zustimmung des Users. Der Website Betreiber wird aber von der EU nicht dazu gezwungen diese Daten zu erfassen. Wenn man keine personenbezogenen Daten erfasst, muss man den User auch nicht mit Cookie Popups und Zustimmung nerven. Natürlich mag manche Foren-Software so programmiert sein, dass man als Betreiber nicht drumrum kommt, aber das ist auch nicht Schuld der EU.
 
Beiträge
9.048
Ort
81249 München
Liegerad
Optima Cheetah
Trike
HP Gekko
Kurz was Grundsätzliches: Ich hatte den Thread nicht gestartet, um ein Tor zum Meckern über Datenspeicherung, Werbung oder Finanzierung des Forums zu öffnen, und ich bitte darum, auch nicht dorthin abzubiegen!
Wer über Reinhards Arbeit als Foren-Admin meckern will, darf gern einen eigenen Thread aufmachen, aber nicht erwarten, dass ich dort mitschreibe. außer vielleicht eine Gegenargumentation.

Die ursprünglichen Fragen, sind jetzt zum großen Teil beantwortet. Offen ist noch, wieso ghostery dazwischenfunkt, obwohl dieses Forum auf der Ausnahmenliste steht. Das ist ziemlich sicher ein Ding zwischen ghostery und dem verwendeten consent manager, denn andere Websites, die CCM19 einsetzen, verhalten sich genauso. Ich habe nicht viel Hoffnung, die Lösung selber zu finden, aber wenn ich darüber stolpere, werde ich's noch hier ergänzen.
 

Reinhard

Team
Beiträge
21.518
Ort
48599 Gronau-Epe
Liegerad
Wolf & Wolf AT2
Ich erinnere mich aber daran, dass es "früher mal" Cookies von (www.)herden.net gab.
Es gibt doch 'ne forenspezifische Werbung, die man u.U. abschalten kann. Und der Ad-Manager dafür läuft halt auf meiner Domain.

Natürlich mag manche Foren-Software so programmiert sein, dass man als Betreiber nicht drumrum kommt, aber das ist auch nicht Schuld der EU.
Das liegt nicht an der Foren-Software sondern daran, dass für Gäste Google-Werbung läuft.
 
Beiträge
1.350
Und auch mein Einsatz von uBlock Origin macht sich nicht negativ bemerkbar. (Ich bin - anders als Reinhard ;-) - der Meinung, dass das Web ohne Blocker kaum mehr sinnvoll nutzbar ist. Natürlich schaltet man / schalte ich auf meinen "Stamm-Sites" fast alles explizit frei.)
Und explizite Tools muss man inzwischen verwenden, damit man bei Problemen (schon in Browser-Standard-Einstellungen wie bei den jüngsten FF-Versionen) schon einsetzen, weil man sonst gar nicht exakt nachvollziehen kann, was wohl das Problem sein könnte.
Und Menschen ohne tiefere Kenntnis davon, wie "das alles" funktioniert, haben tatsächlich gar keine Chance etwas sinnvolles zu diagnostizieren.
So sieht es aus. Bei mir noch mit "eine deutliche Nummer härter" als nur uBlock Origin, nämlich zusätzlich uMatrix. Das Forum funktioniert dennoch einwandfrei (soweit ich es zulasse).
"Blocker aktiv => kein Support" ist nachvollziehbar (und würde ich auch nicht anders handhaben), wird aber kritisch, wenn die Browser zunehmend selbst in diese Rolle schlüpfen. :-/ (Was durchaus sinnvoll ist. Nur die mitgebrachten Werkzeuge zur Verwaltung müssten da noch um einiges handhabbarer "für normale Menschen" werden.)
So sieht es aus. Den pauschalen Ratschlag von Reinhard "Ich kann persönlich nur dazu raten, ausschließlich die Einstellung der aktuellen Browser zu nutzen." kann ich aus seiner (Betreiber)sicht nachvollziehen - aus Sicht eines Internetnutzers aber ganz sicher nicht unterschreiben. Ist halt eine Perspektive und auch "Ich nutze nie irgendwelche Blocker weil die m.E. nur zusätzliche Arbeit machen ... " kann ich für mich nicht nachvollziehen. Die Extrameile ist mir der Datenschutz wert. Und wer seine Webseite gar so gruselig programmiert, dass da ohne Calls auf 378 untersschiedliche Domains und windige Dienste nix geht muss halt auf meinen Besuch verzichten - das ist dann aber ein bewußte Entscheidung von mir. Interessant ist, wie viel man unterbinden kann, ohne dass das irgendwelche negativen funktionalen Effekte hätte und auch, wie viel Mist und datenschutzmässig fragwürdige Calls einem 90% der Webseiten ungefragt auf's Auge zu drücken versuchen und damit ohne uMatrix auch erfolgreich sind.
Allerdings: Um solche Tools wie uMatrix sinnvoll einsetzen zu können braucht es durchaus ein gewisses Grundverständnis und gelegentlich eine gewisse Frustrationstoleranz weil es manchmal mehrere Reloads einer Seite mit schrittweise angepasster Konfiguration braucht, bis sie einwandfrei funktioniert. Dass das und die nicht jeder hat und Reinhard da dann nicht supporten kann und möchte kann ich nachvollziehen. Wie so oft halte ich aber die pauschale "friss, und halt die Klappe oder verzisch Dich"-Aussage nicht für angemessen.
 
Oben