unerklärliche GPS Signalabbrüche am Androiden (mit Locus Pro)

Beiträge
3.435
Vor ein paar Tagen bin ich in Bonn durch die Innenstadt mit dem Liegerad: andauernd Signalabbrüche bzw. Suchen nach einem Signal, auch in der Nähe der Uni, wo es mehr Freiraum nach oben gab. War ziemlich übel, denn ich wollte nachts den
Weg finden.
Hatte (mit locus pro) natürlich vorher in meiner Heimatregion simuliert, wie gut das funktioniert (Hardware S3 mini mit omni rom 5.1.1), allerdings eher auf freier Flur. Null Probleme.
Heute habe ich daher in der Innenstadt gehenderweise mit gps test simuliert, ob ich kurzzeitige Unterbrüche habe, evtl. ein Wackler bei der Verbindung Antenne Platine? Hab aber auch mit Schüttel-Simulation nichts dergleichen feststellen können, selbst an einem +10 stöckigen Hochhaus unterhalb des Vordachs und in verschiedenen Positionen (Handy waagrecht bzw. senkrecht). Nach dem Kaltstart hatte ich innert 1-2 Minuten einen fix. Die Genauigkeit lag maximal bei 15m (meist bei ca. 5-10m). Getestet habe ich nur mit gps test, ohne locus.
Heute den rückwärtigen Kunsstoff-Deckel weggelassen (nur mit Gummi Schutzhülle) und hatte das S3 mini in der Hand anstatt am Liegerad. Kann das so viel ausmachen? Reflektionen durch den Metallrahmen? Zwei Mal hatte ich allerdings nach dem Aktivieren des Bildschirms kurz einen Einbruch (allerdings keinen Verlust). Irgendwelche Energiesparzicken am GPS Sensor? Wie kann ich das unterbinden? Locus pro hab ich so konfiguriert, dass Locus pro als Hintergrundprozess aktiv ist.
Werde es jedenfalls nochmals mit Kunststoff Hülle und am senkrecht am Liegerad versuchen und schauen, ob ich da Unterschiede sehe.
Edit: GPS-Test hat schon die Berechtigung "Ruhezustand deaktivieren", ebenso locus map.
 
Zuletzt bearbeitet:
Beiträge
344
OK, das klingt vertraut, besonders bei Samsung hatte ich das auch früher. Ich nutze Locus seit vielen Jahren auf verschiedenen Androiden. Da gibt es ein paar Einstellungen mit denen das Problem zu beheben sein sollte:

Locus / Einstellungen / GPS und Sensoren:
Deaktivieren wenn Anwendung im Hintergrund => AUS​
die nächsten beiden Schalter => AN​
In den Einstellungen des Androiden je nach Gerät und ROM:
Locus vom Energiesparen ausschließen (wenn möglich)​
Ortung über Mobilfunk etc. ABSCHALTEN also nur GPS Ortung zulassen (ja, die NINA-WarnApp und ähnliche meckern dann, sollten aber eigentlich mit GPS auch zufrieden sein:unsure:)​

Ich nutze zudem seit Jahren die App "GPS Locker", meistens so eingestellt, dass sie nach dem Fix Locus automatisch startet.

Mit diesen Maßnahmen habe ich seit Jahren keine Sprünge oder Lücken in der Aufzeichnung mehr.

Ich hoffe das hilft Dir weiter!

Gruß, Otfried
 
Beiträge
3.435
Locus / Einstellungen / GPS und Sensoren:
Deaktivieren wenn Anwendung im Hintergrund => AUSdie nächsten beiden Schalter => AN
"GPS während der Track Aufzeichnung einschalten" habe ich auf aus, da ich eh nie einen Track aufzeichne. Sonst ist es genauso eingestellt gewesen, wie Du es vorschlägst
In den Einstellungen des Androiden je nach Gerät und ROM:
Locus vom Energiesparen ausschließen (wenn möglich)Ortung über Mobilfunk etc. ABSCHALTEN also nur GPS Ortung zulassen (ja, die NINA-WarnApp und ähnliche meckern dann, sollten aber eigentlich mit GPS auch zufrieden sein:unsure:)
ist genauso schon gesetzt
Ich nutze zudem seit Jahren die App "GPS Locker", meistens so eingestellt, dass sie nach dem Fix Locus automatisch startet.

weiss nicht, versuche, so wenig wie möglich gps Anwendungen auf dem Gerät zu haben, denn ich weiss nicht, ob noch etwas im Hintergrund läuft, was dann Locus in die Suppe spuckt... (konkret habe ich nur Locus maps installiert, selbst GPS-Test habe ich wieder deinstalliert. Werde mir GPS Locker 'mal anschauen, danke für den Hinweis.
 
Beiträge
344
Ja, das war doch mal was mit meinen "tollen" Tips ;-)

Gestern Nachmittag habe ich gesehen, dass Locus trotz gestarteter Aufzeichnung genau NIX aufzeichnet. Also nochmal gestartet, wieder NIX.
Dann versucht mit Strava aufzunehmen, auch NIX :((
Dann mit Naviki, das ging halbwegs schien mir aber auch sehr Lückenhaft.

Letztendlich hab ich das Gerät zu Hause neu gestartet, und heute Morgen lief wieder alles ganz normal.

Hintergrund ist folgender:
Gerät seit ein paar Wochen neu, die Zicken kenn ich noch nicht.​
Regen auf Carbon Velo, zwei Gründe für schlechten Empfang​
Und dann frag bitte nicht, warum ich so viele GPS nutzende Apps drauf habe, es gibt für jede einen Grund und ich habe sogar noch ein paar mehr in Gebrauch. Auf dem Samsung J7 lief das alles problemlos nebeneinander her.

Tatsächlich ist das S3 ja auch schon etwas älter. Ob das Rom das rausholen kann? Vielleicht könntest Du noch versuchen eine dem Alter des Geräts entsprechende Locus Version irgendwo zu finden. Könnte ja sein, dass in der Aktuellen Version Sachen aufgerufen werden, die das S3 gar nicht kann. Aber ein Test mit dem GPS Locker tut ja erst mal nicht weh.

Viel Erfolg wünsche ich auf jeden Fall!
 
Beiträge
3.435
hab die Version 3.46.2 (eine Computer Bild Locus Map Pro Gratis Version) zusammen mit dem omni rom 5.1.1. Gründe: ich fahre das Dingens ohne opengapps/google. Evtl. werde ich einem guten Freund das S3mini samt Locus maps pro geben. Werde den GPS locker dann 'mal testen. Hab Locus maps auch gekauft (sowie auch Osmand+ und Komoot). Die Lust, mich in verschiedene apps richtig 'rein zu fuchsen, nimmt aber immer mehr ab...
Mit Locus und ein paar Karten (NRW, Rheinland-Pfalz und Schweiz) ist der Speicher vom S3 mini fast voll. Ist bewusst so "konzipiert", um SD Karten Probleme auszuschliessen. Würde mir auch genügen, wenn die eine app denn wirklich funktioniert. Brauch halt viel Kniefreiraum beim Anfahren, daher ist mir ein kleines Teil als GPS-Handy sehr genehm. Evtl. gibt's aber doch noch ein upgrade auf ein Sony Z1C... Welches ist denn das zickige neue?
Tja, der Neustart als Zaubermittel, schon seit Jahrzehnten bewährt...
Die Zicken in Bonn hatte ich übrigens am Ostrad Adagio, ohne irgendwelche Abdeckungen bzw. Verkleidungen. Das Handy ist dort quasi senkrecht montiert gewesen anstatt schräg zu liegen. Viel Geduld beim Herausfinden der "neuen" Zicken wünsche ich Dir!
 
Zuletzt bearbeitet:
Beiträge
3.435
@Ot_Be : Bin gerade wg. Deiner Aufzeichnungsproblemchen über folgendes gestolpert: "Bitte beachten Sie das der Wert den Sie hier hinterlegen kleiner oder gleich jenem Wert ist den Sie in den Aufzeichnungsprofilen hinterlegt haben (Einstellungen > Track Aufzeichnung – Aufzeichnungsprofile) da der Trackpunkt sonst u.U. nicht gespeichert wird." Hast Du darauf geachtet?
https://www.locusmap.app/de/save-the-battery-gps-auto-off-feature/
GPS-Auto aus ist bei mir übrigens inaktiv bzw. auf "off".
GPS Ortung deaktivieren:
"Deaktivieren, wenn die Anwendung im Hintergrund ist" ist auch auf "off"".
Nach der Installation von gps-locker (apk von apkpure) habe ich zuerst locus nicht auch als autostart sondern nur als quickstart icon gesetzt..., jetzt klappt's. Allerdings überschneiden sich doch einige GPS-Einstellungen von locus mit denen von gps-locker.
Habe auch getestet, ob die Handy-Halterung (ein billiges China Plastik-Dingens) einen Einfluss hat: die Werte in gps-locker unterscheiden sich zwar merkbar, aber nicht drastisch.
 
Zuletzt bearbeitet:
Beiträge
344
Welches ist denn das zickige neue
Poco x3 pro also ein Xiaomi, relativ günstig und erst mal reichlich Speicher und ordentlich Akku.
wg. Deiner Aufzeichnungsproblemchen über folgendes gestolpert:
GPS Auto aus hab ich seit Jahren in allen Geräten immer aus. Abgesehen davon hat es ja auch auf dem Neuen gut 2 Wochen sauber funktioniert. Ich hoffe mal, das Problem mit 2 bis 3 Neustarts pro Woche unterdrücken zu können...
China Plastik-Dingens
wundert mich, dass das Einfluss hat, dann ist es wohl doch nicht nur Plastik ;-)
 
Beiträge
3.435
Ganz ohne Metall geht's nicht, insbesondere wenn da noch ein Rahmenrohr in der Nähe ist, sollte aber nicht allzu grossen Einfluss haben.
Wg. Poco: hatte früher ein Xiaomi Mi5, bestes GPS ever.
 

Anhänge

  • IMG_20210929_101854.jpg
    IMG_20210929_101854.jpg
    116,5 KB · Aufrufe: 7
  • IMG_20210929_101908.jpg
    IMG_20210929_101908.jpg
    110,1 KB · Aufrufe: 6
Beiträge
18.257
Heute habe ich daher in der Innenstadt gehenderweise mit gps test simuliert, ob ich kurzzeitige Unterbrüche habe, evtl. ein Wackler bei der Verbindung Antenne Platine? Hab aber auch mit Schüttel-Simulation nichts dergleichen feststellen können, selbst an einem +10 stöckigen Hochhaus unterhalb des Vordachs und in verschiedenen Positionen (Handy waagrecht bzw. senkrecht). Nach dem Kaltstart hatte ich innert 1-2 Minuten einen fix. Die Genauigkeit lag maximal bei 15m (meist bei ca. 5-10m). Getestet habe ich nur mit gps test, ohne locus.
Ich hatte mal bei Google Maps ähnliche Problem, und da waren es die StromsparModi des Handies.

Mehrere GPS-Programme sollten sich eigentlich nicht stören.
 
Oben Unten